Problem with passbolt, show "could not verify server key"

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Hello, we are having a problem with our passbolt, it is in a linux virtual machine, this machine was closed and would not start, after getting into recovery mode I saw that the disk was full, I did a cleaning and I could access, but to access the server does not start, it tells me that it can not verify the key, if I put to update the server I get the following error

I have also tried to move the entire database to another system with passbolt newly installed, but I get the same problem.

This is the result of the health check command

Hello @quetebe and welcome to the forum!
Have you checked the database credentials?
Maybe they were pasted incorrectly or the machine running the Passbolt instance doesn’t have access to the database server.

Hi, I have given permission to all users in all passbolt folders in case that was the problem, and the credentials have not been changed, also I am not clear which ones they have to match with I suppose, if I go into the passbolt.php file it has the keys well I put in.

please, could you share the output of:

  • sudo ls -la /var/lib/passbolt/.gnupg
  • sudo ls -la /etc/passbolt/gpg

Also, can you try to manually logging in to MySQL with the credentials presents in /etc/passbolt/passbolt.php ?

I also try to connect with ssh

Thanks for the screenshot, as you can see it looks like it can even run MySQL CLI, it might be disabled and causing the issues.

Please, can you try to run:

sudo systemctl status mysql

If this is disabled or inactive, you might want to run:

sudo systemctl enable --now mysql
sudo systemctl start mysql

I did a cleaning and I could access, but to access the server does not start,

I think that after restarting the server, you might encountered an issues stopping MySQL to start

First, thank you very much for all the help, second, you are right, the mysql CLI is not starting, what could I do in this case?

It looks like MySQL is failing to start :thinking:

As it is mentioned in the logs, could you share the output of:

sudo journalctl -xeu mysql.service

Also, you mentioned earlier:

I saw that the disk was full

Is it solved? what are the outputs of:

df -h
df -i

i’m short on space, but i thought it would be enough.

I would recommend that you free up some space, that is very little space.