The server response could not be parsed

Trying to add a newly created user to an existing (4000+ passwords) group I receive this:
Unexpected
A group admin and also I as server admin with group admin privileges both have received the same error.
I do not see anything in server’s /var/log/passbolt/error.log
I have cleaned with ./bin/cake passbolt cleanup

Any idea?

Check for the server logs (nginx/apache logs depending on your installation). It might be the webserver timing out or the request being too large. You may need to tweak the settings.

On retrying I get this:
2023/01/24 10:12:34 [warn] 24155#24155: *767512 an upstream response is buffered to a temporary file /var/lib/nginx/fastcgi/6/27/0000002276 while reading upstream, client: 147.161.191.92, server: 35.195.178.226, request: “PUT /groups/40146767-c175-470a-80b4-d4c0af3124d6/dry-run.json?api-version=v2 HTTP/1.1”, upstream: “fastcgi://unix:/run/php/php7.3-fpm.sock:”, host: “[xxx.xxx.xxx.xxx]”

Four minutes later, after all the decrypting and encrypting, I get this:
2023/01/24 10:16:25 [error] 24155#24155: *767577 client intended to send too large body: 5395137 bytes, client: [xxx.xxx.xxx.xxx], server: [xxx.xxx.xxx.xxx], request: “PUT /groups/40146767-c175-470a-80b4-d4c0af3124d6.json?api-version=v2 HTTP/1.1”, host: “[xxx.xxx.xxx.xxx]”

@NoelTorres This confirms what @remy was suggesting. It is exceeding the client_max_body_size in NGINX.

@garrett changed it from 5M to 10M and it worked.
Thanks.
@remy Thanks to you too. I didn’t fully understand (in your answer) what to touch to resolve it, but I understood the basis of the problem.

4 Likes