We sent a link to verify you email

“Hello everyone,
I have configured Passbolt on a CentOS server and successfully logged into the web interface with my admin credentials. Everything seemed to be fine and working. However, when I created a new user to grant them access, they encountered an issue. Whenever the user tries to log in, they receive a notification stating, ‘We sent you a link to verify your email,’ but unfortunately, the user never receives the verification email. I’ve tried a few solutions, but nothing has worked so far. Could someone please help me with this? Thanks.”

I used this link to configure passbolt on centos

Thank you

Hello @prudhvi , thanks for reaching us.

:warning: I am really sorry to start like that, but I am already highly recommending migrating to a new server as the end of life for CentOS 7 is schedule for June 30th 2024.

Regarding the email issues, from what you are describing, if you are creating a new user, they should not navigate to the instance URL and try entering their email, they should receive a “Welcome to passbolt” email.

If this email is not sending properly, have you tried to take a look at our dedicated guide? Also, does all the other emails are working well?

Ideally, please share a screenshot of Administration > Email notification and also from Administration > Email server what are the logs from the email test?

thank you for the quick response

here it is the users manage page in the above image one is admin user that is mine and another is user that I created. when user try to login after entering his mail a message appears we are sending invitation to verify your email, but never receives a mail. this is the problem

It looks like the user is not activated yet , this is why he won’t be able to logging in via the web url. Please, right click on the user and click on “Resend invite”

I did many times but user never receives anything

I see that you are using TLS with the email server settings. If it is using a self-signed certificate, have you followed our dedicated documentation?

In the meantime, what I would recommend as a workaround would be to use the CLI to generate the URL. Since the account has never been configured, from the user interface you can Right click on the inactive user > Delete. Then from the CLI, you can run:

sudo su -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt register_user -i" nginx

This will prompt an URL that you can share with the user.

Thank you. I used CLI to generate URL it is working but unfortunately still no mail received. Yes, I have follwed dedicated documentation for self-signed certificate but still no useful.

Is there any other way to solve this?

can you share the response when you send a test email from Administration > Email server ?

test mail is working