Blank Screen after SSL Installation

I initially set up passbolt through AWS AMI and it was working perfectly in the unsecured mode (no SSL installed). I tried adding the SSL certificate today through the let’s encrypt method but it failed to complete as I said that I have to mention the server URL in NGINX Setup which I am not familiar with. I tried googling but was not able to find a proper solution.

Then I moved onto the manual installation and gave the path to SSL Certificates which were created by let’s encrypt. It showed a blank screen -

I thought it may be an issue with my assistant certificate so I created another one from Zero SSL and install data using the manual method. I am still getting a blank page. No Error in logs.

Please suggest, what should I do

Hi @parvvfect The issue is that the content of the passbolt files are being requested unsecurely from so the browser will not load them. The change needed is in the configuration file so that the URL the app thinks it’s serving from is https instead of http. Look for /etc/passbolt/passbolt.php to change the fullBaseUrl setting.


I love you @garrett …you spared me some trouble…thats was my problem too :slight_smile:

But if you now use a inventaion mail it would be redirected to http, how can i change this behaivor too?

Worked like a charm. Thanks a ton for your help :slight_smile:

1 Like

@yoloknight Can you start a new thread and provide install version and host OS, thanks.