Cannot Create a Password (firefox): Unexpected Error

I just installed a new version of passbolt.on Ubuntu.
I login to passbolt via the url.
I complete the new password form.
The system process the form and then returns the following error:

There was an unexpected error…

An Internal Error Has Occurred.

On a related note the helathcheck has three (3) errors. However, we are using a letsecnrypt certificate.

[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
[HELP] Check that the domain name is correct in config/passbolt.php
[HELP] Check the network settings

SSL Certificate

[FAIL] SSL peer certificate does not validate
[FAIL] Hostname does not match when validating certificates.
[WARN] Using a self-signed certificate
[HELP] fopen(): SSL operation failed with code 1. OpenSSL Error messages:
error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed
fopen(): Failed to enable crypto
fopen(https://[XXXXXXXXXXXX]/healthcheck/status.json): failed to open stream: operation failed

Please advise.
Thank you.

@Roberts Make sure domain is noted in the /etc/hosts file and follow any/all help instructions in the healthcheck with the objective being to have a clean healthcheck.

Also, if you are describing the creation of the first user then I think you are referring to the passphrase for the user and this may help if you are searching the forum for previous questions related to this.

Thank you for your quick reply!

Adding the FQDM to the host file worked like a charm. Health check passed with flying colors.

However, the error when i try to create a password with the admin user fails with internal error. I will mark this post as solved and post another.

Thanks again.

1 Like