Can't access web interface


I am using passbolt for the first time, the docker-compose version on Linux 20.04. In my command line everything seems to be running, but I can’t open the web interface. I have passbolt plugin installed, but that just tells me, that it requires the server to work. I’m not quite sure if I was supposed to do something else before running the docker-compose up.

I have also changed passbolt ports in docker-compose.yml to:
- 8880:80
- 8443:443
but after trying localhost:8880 I get relocated to https:// passbolt.local/auth/login and Server Not Found error.

____ __ ____
/ __ ____ _____ / / ____ / / /
/ /
/ / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell


[PASS] PHP version 7.3.21.
[PASS] PCRE compiled with unicode support.
[PASS] The temporary directory and its content are writable.
[PASS] The public image directory and its content are writable.
[PASS] The logs directory and its content are writable.
[PASS] GD or Imagick extension is installed.
[PASS] Intl extension is installed.
[PASS] Mbstring extension is installed.

Config files

[PASS] The application config file is present
[WARN] The passbolt config file is missing in /var/www/passbolt/config/
[HELP] Copy /var/www/passbolt/config/passbolt.php.default to /var/www/passbolt/config/passbolt.php
[HELP] The passbolt config file is not required if passbolt is configured with environment variables

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to https://passbolt.local
[PASS] App.fullBaseUrl validation OK.
[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
[HELP] Check that the domain name is correct in config/passbolt.php
[HELP] Check the network settings

SSL Certificate

[FAIL] SSL peer certificate does not validate
[FAIL] Hostname does not match when validating certificates.
[WARN] Using a self-signed certificate
[HELP] cURL Error (6) Could not resolve host: passbolt.local


[PASS] The application is able to connect to the database
[PASS] 23 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[PASS] The environment variable GNUPGHOME is set to /home/www-data/.gnupg.
[PASS] The directory /home/www-data/.gnupg containing the keyring is writable by the webserver user.
[PASS] The server gpg key is not the default one
[PASS] The public key file is defined in config/passbolt.php and readable.
[PASS] The private key file is defined in config/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in config/passbolt.php.
[PASS] The server public key defined in the config/passbolt.php (or environment variables) is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt a message.
[PASS] The private key can be used to sign a message.
[PASS] The public and private keys can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.
[PASS] The private key can be used to decrypt and verify a message.
[PASS] The public key can be used to verify a signature.

Application configuration

[PASS] Using latest passbolt version (2.13.5).
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[WARN] Registration is open to everyone.
[HELP] Make sure this instance is not publicly available on the internet.
[HELP] Or set passbolt.registration.public to false in config/passbolt.php.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

3 error(s) found. Hang in there!


By default passbolt will try to enforce https. You should be able to access passbolt at https://localhost:8443. If you want to access it with http (which is a bad idea in production, but for testing it’s ok), you will need to set the environment variable to PASSBOLT_SSL_FORCE to false.

Also it seems the URL is set to https://passbolt.local and you want it to be localhost.
You can redefine the host using the APP_FULL_BASE_URL environment variable to localhost. Alternatively you can map passbolt.local in your /etc/host file on your local machine.       passbolt.local

The problem is that whatever I do I get “We can’t connect to the server at www.passbolt.local.” or something along these lines, including https://localhost:8443. When I connect to said adresses, the log in command lines writes:
passbolt_1 | - 18/Aug/2020:10:44:53 +0000 “GET /index.php” 302
passbolt_1 | - - [18/Aug/2020:10:44:53 +0000] “GET / HTTP/1.1” 302 5 “-” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:79.0) Gecko/20100101 Firefox/79.0”

but in browser I get Server Not Found error

Got it,

it turned out that I just didn’t understand your answer. Changing PASSBOLT_SSL_FORCE to false and changing APP_FULL_BASE_URL to http://localhost:8880 did the trick.

Thank you very much for your help.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.