Passbolt not accessible using docker-compose

I installed the passbolt using docker-compose. I followed the

I changed the port of passbolt to 9000 instead of 80 in the docker-compose.yml.

I tried to run the docker-compose -f docker-compose.yml up and checked the https://passbolt.local in the browser and I cannot load the passbolt.

I also tried to create account

and follow the link from the result and still cannot access the passbolt from the browser. Why is it not loading? Thanks


Sorry you experience problems with passbolt composer setup. Could you provide the changes you made and which problem are you facing when loading your passbolt instance website?

This is still the default values from the downloaded passbolt-docker

on the right side I change the ports of db to 3306**
and the passbolt container port to 9000:9000 instead of 80 because I keep getting conflicts.

Thanks for the information!

Just another question, do you have an entry on your /etc/hosts pointing passbolt.local to ?

Yup I added passbolt.local in my /etc/hosts/ and when I access it from the browser http://passbolt.local I returns my default nginx page because it’s dedicated for my

Correct me if I’m wrong, the port 9000:9000 in the docker-compose passbolt container is the passbolt’s default port? if so do I need to change also the port to 9000 in the /etc/hosts ?

Thanks for your response

Passbolt container by default comes with 2 ports open 80 and 443.

  • Port 80: open for people who do SSL offloading before the requests arrives to passbolt container
  • Port 443: for standalone setups with SSL

By default passbolt sets PASSBOLT_SSL_FORCE env variable to true so any request arriving to http://passbolt.local gets redirected to https://passbolt.local. In your case any request arriving to http://passbolt.local:9000 gets redirected to https://passbolt.local.

I guess you want to redirect host port 9000 to port 80 of passbolt container to match what I described above. In that case, your docker-compose.yml should look like:

      - 9000:80
      - 443:443

@diego it’s working now. we’re going to evaluate the community version first. Thanks for your responses.

@allenchun you are welcome, glad to see it’s working now!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.