Connection timed out after install on browsing


I managed to install passbolt untill ./bin/cake passbolt install

The problem comes right after that when I try to visit the activation link provided in the console after successfull install : I get a connection timeout.

I have nginx server running on top of a recent standard debian distro. Here is my nginx vhost config:

    listen 80;
    listen [::]:80;


    charset     utf-8;

    root /var/www/; # this is correct
    index index.php index.html;

    location ~ \.php$ {
            include snippets/fastcgi-php.conf;
            fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
   location / {
           try_files $uri $uri/ =404;


The healthcheck is OK for the most part. I only have ssl errors (which is natural since I don’t have ssl setup yet) and this :

[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
[HELP] Check that the domain name is correct in config/passbolt.php
[HELP] Check the network settings

Which I don’t understand because this parameter should be ok imo :

'App' => [
    // A base URL to use for absolute links.
    // The url where the passbolt instance will be reachable to your end users.
    // This information is need to render images in emails for example
    'fullBaseUrl' => "",

I think my nginx config might be wrong since original install with apache requires url rewritting, and I’m not sure how nginx handles that…
So I’ve tried different things :

  • Restarting nginx server every time a change was made
  • Trying an other nginx config from this post
  • I’ve tried adapting config from this post as well
  • I’ve tried changing fullBaseUrl to http, https, with and without subdomain

And now I’m a bit at a loss…

If it was just me, I would have used Apache and done just like in installation documentation since I’m not very good with server configuration. But my company already has a super-tiny server with nginx on it and other applications configured. So switching to Apache is not an option here.

edit : ALso, I don’t know it it’s right but every file and folder inside /var/www/ is owned by www-data user. I don’t know if this is right but that’s how I have proceeded for other installs. I’m not very good with linux permission system so I might have messed up something here too

Any hint ?

Also, I’ve just noticed now but I have lost the activation link in the process of testing and troubleshooting… Is there anyway to recover it or do I need to install the whole thing again ?

Hello @AntoineD,

Is the domain you mentioned an existing domain ? Or a domain you are using for the test ?
Is it reachable on your network ?

If you created it for the test and it is not reachable on the network, you will need to configure the /etc/hosts of the system you are trying to access the domain from.


Thank you for your answer @cedric is an alias as I didn’t want to disclose this info here.

The actual domain is up and running with correct DNS records.

To make it clear, I have one vhost on serving our client’s website, and I want to install passbolt to be served when accessing

I have tested the vhost for this subdomain with a hello world php file and its working properly (meaning its neither a DNS mistake, nor a misconfig on nginx as far as root directory, server_name, or proxy is concerned.

If it’s still not clear to you, please feel free to ask more questions

Hi @AntoineD!

Sorry to hear that you are experiencing problems installing passbolt. Have you checked our help site? There is a passbolt install tutorial step by step for centos that involves nginx in the stack. Maybe you can compare your configuration with the one provided here:

Also in order to help you a bit more would be nice to see some logs from logs/error.log and/or nginx access/error log

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.