Debian 11 Installation

Are there plans to provide passbolt for Debian 11 (stable)?

I just upgraded my server from 10 to 11 today and I think I broke passbolt in the process (curse you PHP and your endless config file changes and etc!)

Can anyone point me in the direction of some good logs I could use to figure out what broke my installation? I assume it was the PHP upgrade but I don’t know where to go from there.

I tried a dpkg-reconfigure passbolt-ce-server to no avail.

I will check back in with some better information once I get an idea for what is/isn’t working. At the moment nginx doesn’t like my SSL certificates despite the reconfigure so I will probably start by looking at the nginx configs.

Hi @TheFunk35 and welcome to this forum :handshake:

We didn’t still communicate on this but current Passbolt package is already compatible with current Debian 11 stable release, aka Bullseye.

The bullseye branch is still not created in our Debian repository and our documentation is not up-to-date but it will be fixed in the coming days.

Coming back to your issue, I just performed a dist-upgrade on a current passbolt install on Debian 10 and here is a list of what happened:

  • PHP 7.3 has been replaced with PHP 7.4
  • mariadb-server-10.3 and mariadb-client-10.3 have been removed

To fix this, I edited /etc/nginx/sites-enabled/nginx-passbolt.conf file, I replaced the php version on line 36 to match the installed PHP version:

fastcgi_pass             unix:/run/php/php7.4-fpm.sock;

Then, I reloaded nginx web server:

sudo systemctl reload nginx

And for MariaDB server. I installed this package:

sudo apt install default-mysql-server

As MariaDB packages were removed but not the Passbolt database, it fixed the issue and Passbolt is running fine with Debian 11.

Let me know if you need assistance with your SSL problem, but looking at nginx logs is a good starting point.

Best,

1 Like

I just retried the Debian 10 => 11 upgrade process.

The first time, after editing /etc/apt/sources.list for Debian 11, I made:

apt upgrade # This one has removed default-mysql-server package and so mariadb
apt dist-upgrade 

The second time, after a snapshot restore to Debian 10, I edited again /etc/apt/sources.list to put Debian 11 sources. I made the dist-upgrade without the upgrade before.

I got this message and mariadb was not removed, but it was not upgraded to 10.5 version.

The following packages have been kept back:
  default-mysql-server

I ran again apt dist-upgrade and default-mysql-server was upgraded, so MariaDB was upgraded too to 10.5 version.

The dpkg-reconfigure passbolt-ce-server won’t edit nginx config file to replace 7.3 with 7.4 for php socket. So you just have to edit this and reload nginx.

FYI

2 Likes

Hello! Well I had an interesting experience. I’m not sure what caused this weirdness, but here’s what I had to do to resolve the problem:

First I made the PHP version change to use the 7.4 socket. To future proof I used the symlink in /var/run/php/

So instead of using php7.4-fpm.sock my config file uses php-fpm.sock
Whenever Debian’s PHP version receives a major upgrade this symlink will point to the newest unix socket.

I needed to install default-mysql-server

And then to resolve the SSL error I had to do the following:

In /etc/passbolt/nginx-ssl.conf I needed to remove the [::]: in front of the 443 in the listen directive.

Then in my sites-enabled directory I needed to remove the listen 443; directive from my nginx-passbolt.conf.

Finally sudo systemctl restart php7.4-fpm mariadb nginx

And that resolved the problem.

Also, off topic but I dig the old school hacker glider avatar. Got that tattooed on my wrist.

Hi @TheFunk35

Thanks for your feedback about how you resolved your issue, and yes, I chose this avatar because I like the hacker spirit :wink: Good tatoo choice :stuck_out_tongue:

About the php-fpm symlink, how did you create it ? If created by hand, it will disappear on next reboot as files in /var/run folder are not persistent.

Regarding your nginx issue, your server has an IPv6 ? If yes, there is an known-issue with passbolt nginx configuration files and the default nginx virtualhost => Not able to install Passbolt CE on Ubuntu 20.04 with Let's Encrypt - #5 by _jc

Maybe it is related :thinking: ?

Could be related. I’ll have to check later but I don’t believe I disabled IPV6 so it should have an IPV6 address.

The php-fpm symlink is automatically created/updated when you install/update PHP in Debian. It should be in /var/run/php/ for you, already. If it’s not then maybe it is a different package than php7.4 that sets that up for you.

1 Like

By the way, thanks for your feedback, it was very helpful :+1: for the ones who want to use Debian 11 now.
The official documentation for installing / upgrading to Debian 11 will be released in the coming days/weeks.