Installation Issues - empty passbolt.php file

I have read intro post
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I’ve encountered a couple different issues with my passbolt installation and the current issue is the passbolt.php file is empty, though that’s probably a symptom of a larger issue.

What I did:

  1. Install Dietpi on a new Raspberry Pi 4.
  2. Follow Passbolt Help | Install Passbolt CE on Raspberry PI - After the database setup I got an error

The error I saw was “Errors were encountered while processing: passbolt-ce-server”. That led me to a similar issue on this forum where I then realized the actual error was the mysql command, it appears mysql didn’t install. I manually installed mariadb-server and then tried to run the “sudo apt install passbolt-ce-server” step again.

I initially ran into this error: “ERROR 2002 (HY000): Can’t connect to local server through socket ‘/run/mysqld/mysqld.sock’ (2)”, but that self resolved. I guess the process hadn’t started up fully yet or something.

It then let me continue through the nginx step, but at the end my passbolt.php file was empty and I saw the default nginx page. I then proceeded to reconfigure with “sudo dpkg-reconfigure passbolt-ce-server”, this time with no SSL, just the IP. Same result. I tried adding a " fullBaseUrl" as this tutorial suggests: Passbolt Help | Auto configure HTTPS with Let's Encrypt on Debian and Ubuntu, but I don’t know the file structure so that just causes an error.

This is a completely fresh install, so I’m happy to restart, uninstall, provide logs, or any other steps, I’m just lost with how to get this running. It seems like every command I run breaks somehow.

Hello @vforvendettaicecream and welcome to the forum!

From what you say, the installation just broke somewhere. Where? I’m not sure.
I did an installation once on a Raspberry pi 4 and it went well, however, I was using the default OS.
I didn’t know about Dietpi. Maybe some dependencies are missing or some behaviour are different than what we expect.

I would suggest to retry the installation from scratch if possible and ensure first that mariadb-server is installed before you start the installation process.

If you can’t do that, does your passbolt.php file has been fulfilled after the reconfigure?

1 Like

Thanks for recommending a re-install from scratch. I did that again with dietpi, but this time I installed mariadb-server before passbolt and it worked as far as I can tell!

That’s nice if you were able to finish the installation!

Enjoy it :slight_smile: !

1 Like