"email not associated with any approved users on this domain" [badly formed recovery key]

I set up Passbolt a few months ago (Mac Monterey 12.5.1). I have all my credentials and Passbolt as extension on Chrome, but I have not used it till today.

I try to log in my account from the extension. It tells me to go to my email and click on the link my organization sent me. I do it, but I see a screen with “this email is not associated with any approved users on this domain. Please contact your administrator to request an invitation link”.

What can I do on my own to fix this? Why do I need to contact the administrator if my registration months ago was successful?

I also try to recover my account with my private key. The problem is that I have it in pfd, and apparently I cannot upload the provate key file as pdf. Txt files are accepted, but converting the pdf to a txt file changes the characters, making them invalid. I also tried to copy-paste the key, but it is too long and it is pasted with spaces. I erased the spaces (which took ages), but that did not work.

Anyone has encountered a similar issue?

Hi @MoniT I’m sorry to hear about this, seems frustrating.

Are you the admin for the system? If not, you should tell them about this so they can help.

You could try importing the pdf into Word and then making a text file from there.

Successful registration with the extension does two things: it finishes the setup in the system for you as a user, and it establishes your extension as authorized in that browser.

If the extension gets reinstalled for any reason, the extension will need to get re-authorized for access in that browser. Same deal with the scenario of simply using a different browser.

Hi Garret,

Thanks a lot for your reply and your explanation, it helps me understand this a bit better :slight_smile:

I tried creating a txt file from word, but still it does not work. I get the error “The key should be a valid openpgp armored key string”. I looked up for this issue in the forum and I have not found something matching it. I don’t understand why the key is not valid, or what I could change to make it valid.

I am not the admin, but I will contact them since there is not solution yet.

Out of curiosity, did you make the pdf or was it given to you?

I asked myself the same question, but I actually don’t remember.

I did not convert the file to pdf on purpose, or I would remember. So maybe I was given the option when I created the Passbolt account and decided for pdf.

I just know that I had the file in pdf format since i created the account :thinking:

The app offers the user a “recovery kit” file which contains the key, but it’s not a pdf.

Typically, when a user of a working passbolt installation gets the message you did its because they are no longer a user of the app. In other words, the account with that email address has been deleted by the admin.

But since you are not the admin, it might be an older version of the app. In the lower right corner of the site there are hearts you can hover over to see the versions. What versions do you see?

Ok, I see!
I checked the version, it says 3.8.2.
Thanks for following up with my issue!

1 Like

That’s not an old version, so in theory if you set up the account for yourself you should have been offered /instructed by the app to download a recovery kit.

However, the admin may have recently updated the app, which may be also why there is a problem with your access. Maybe it was an older version when you signed up.

Best of luck sorting it out with the admin!

I got a helpful reply from customer support, which solved the issue.
The “begin block” and “end block” of the secret key were formatted wrongly in the pdf file. I needed to add an extra empty line and remove an empty space. Here is the correct format:




I was able to recover my account successfully :slight_smile: