Email not sending [Office365 app password needed]

Hi guys,
Previously my passbolt worked perfect. Until yesterday. My whole email system is not working anymore. I am running passbolt in a docker. I can reach the website of my hosted passbolt.
But i will always stay stuck at this screen.

Can anyone help me a bit forward. Previous topics i couldnt make it.

Hi @samvos21 Welcome to the forum!

So what do you think changed in your setup?
Did you run a healthcheck?
What version are you running?

Have you gone through these items? Passbolt Help | Why are my emails not being sent?

Please report back what you have done and checked, and we may be able to help with some additional ideas, thanks.

I just wanted to chime in and say I am having the same issue all but I have a fresh install of v3.11.0 on Ubuntu 22.04.

Running a healthcheck doesn’t show any issues and sending a test email with the “cake passbolt send_test_email” sends the email perfectly.



I had ran the clear cache command and it didn’t do much but for fun I rebooted and ran the clear cache command again and it appears to be working again (odd for a fresh install but if it works it works)

@samvos21 if you haven’t given that a try, see what that does

My command test mail is not recognized, what line do you use? Thanks for the help!

I am trying to contact my hosting provider to see if there is a fault.

Can anyone write down a line how I can see the ‘stuck’ emails?

Look for a db table called email_queue.

1 Like

To help you along with the query for that:

select email, subject, error, created, sent from email_queue;

This should give you some useful information about which ones are sent or not, any errors, and which emails they were

@samvos21 So you were right! Does this resolve it for you?

So how to change those mail settings. I am sorry for bothering you

You can change it in /var/www/passbolt/config/passbolt.php (or your Passbolt installation folder)
You should have something like this:

'EmailTransport' => [
        'default' => [
            'host' => '',
            'port' => 25,
            'username' => '',
            'password' => 'password',
            // Is this a secure connection? true if yes, null if no.
            'tls' => null,
            //'timeout' => 30,
            'client' => '',
            //'url' => null,

@Termindiego25 happy cake day!

Since we’ve moved SMTP settings to the database instead of the file the best way to change this is going to be in the Web UI under the administration tab. @samvos21 are you still logged in with your admin account?

1 Like

Thank you! :smile:

As @clayton said, you can find the configuration in your server website, under Administration (in the top bar menu) and by selecting Email server at the left menu:

Also, you can find more information here, maybe helps you:

Sadly I can’t login with my admin account because of the ‘verification’ mail. Otherwise I could do it in the GUI

No worries, there is a way around that.

  • Request the recovery email to be sent even though it won’t go anywhere
  • Log into the server, and then the database, and be sure to use the passbolt database if you don’t default into that one
  • Run this query:
    • select email, subject, template_vars from email_queue order by created desc limit 3;
      • I chose 3 here in case someone else tries to recover their account too

Your output should look something like the below, I’ve bolded two important fields which you’ll need:

| clayton@passbolt.local | Your account recovery, C! | {“body”:{“user”:{“id”:“73a51858-0435-47d5-bc7f-62eb7ff10590”,“role_id”:“15537ea1-46cd-4e12-b2f9-a50c818b60a2”,“username”:“clayton@passbolt.local”,“active”:true,“deleted”:false,“created”:“2022-11-21T11:15:48+00:00”,“modified”:“2023-02-15T15:50:34+00:00”,“profile”:{“id”:“865a9a8d-60e8-4a11-bf05-f26ea6aa2a2b”,“user_id”:“73a51858-0435-47d5-bc7f-62eb7ff10590”,“first_name”:“C”,“last_name”:“S”,“created”:“2022-11-21T11:15:48+00:00”,“modified”:“2023-02-15T15:50:34+00:00”,“avatar”:{“id”:“2b814079-edc8-4739-9b97-235ea03b05bc”,“profile_id”:“865a9a8d-60e8-4a11-bf05-f26ea6aa2a2b”,“created”:“2023-01-02T11:56:55+00:00”,“modified”:“2023-02-15T15:50:34+00:00”,“url”:{“medium”:“https://passbolt.local/avatars/view/2b814079-edc8-4739-9b97-235ea03b05bc/medium.jpg”,“small”:“https://passbolt.local/avatars/view/2b814079-edc8-4739-9b97-235ea03b05bc/small.jpg”}}},“role”:{“id”:“15537ea1-46cd-4e12-b2f9-a50c818b60a2”,“name”:“admin”,“description”:“Organization administrator”,“created”:“2012-07-04T13:39:25+00:00”,“modified”:“2012-07-04T13:39:25+00:00”},“last_logged_in”:null},“token”:{" user_id":“73a51858-0435-47d5-bc7f-62eb7ff10590”," token":“98cec5d3-5b87-4ec7-8aad-cafe0cf9b6e3”,“active”:true,“type”:“recover”,“data”:null,“created”:“2023-02-17T13:37:07+00:00”,“modified”:“2023-02-17T13:37:07+00:00”,“id”:“b0dffa11-8e9c-4434-878d-4ed22d9a107b”},“case”:“default”,“fullBaseUrl”:“https://passbolt.local”},“title”:“Your account recovery, C!”,“locale”:“en-UK”} |

You should then be able to go to the Administration settings to correct the email issue

Everything went well exepect this message:

The email are you waiting for is the activation email or a recovery email?
Do you have your recovery-kit.txt downloaded?

oops i dont have the recovery kit… is this a big problem?

Well first i used the method someone said above then that screen came up

Try with the activation URL instead of the recovery one.
You should go to your database and find on the email_queue table the data you need. Search for "token":{"user_id":" and you will find your user_id and your activation token.

Then replace here:$user-id/$token

If you have not saved your recovery-kit or private key, you will not be able to recover your account or login on new devices unless you have PRO edition and have recovery process activated

/setup/install is not working. Strange cause this is the only email thats activated.