Issues to upgrade from CE to Pro (v2)

Hello dream team.

I have passbolt CE v2 running on a centos 7 VM and Docker compose to run this app.

So far, everything went good until I wanted to upgrade to the Pro version. I have made backups before diving to the upgrading. However issues arised:
1. it does not accept the password of the database.

-e DATASOURCES_DEFAULT_PASSWORD=***K&a

It ends with an “a” and throws an error:

[1] 6859

-bash: a: command not found

If I remove the last “a” or change it for a “b”, it gives this error:

[1] 7480
-bash: b: command not found

[1] 7148
-bash: -e: command not found

2. I tried to run the command without the password and I got another error:

docker: Error response from daemon: create /root/backup/subscription: “/root/backup/subscription” includes invalid characters for a local volume name, only “[a-zA-Z0-9][a-zA-Z0-9_.-]” are allowed. If you intended to pass a host directory, use absolute path.

I suppose that the subscription is incorrectly setup. I put the sub key into a text file, this text path is /root/backup/subscription

This is the full command I tried:

docker run --name passbolt-pro --net passbolt_network --mount source=~/backup/volume_images,target=/var/www/passbolt/webroot/img,type=bind --mount source=~/backup/subscription,target=/var/www/passbolt/config/license --mount source=~/backup/volume_gpg,target=/var/www/passbolt/config/gpg -p 443:443 -p 80:80 -e DATASOURCES_DEFAULT_HOST=*** -e DATASOURCES_DEFAULT_PASSWORD=…K&a -e DATASOURCES_DEFAULT_USERNAME=*** -e DATASOURCES_DEFAULT_DATABASE=*** -e APP_FULL_BASE_URL=https://. passbolt/passbolt:latest-pro

PS: I never managed to do an healthcheck, sorry if it is missing :slight_smile:

Checklist
[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[x] I describe the steps I have taken to trouble shoot the problem
[x] I describe the steps on how to reproduce the issue

Hi @horuskov, could you please open a ticket through contact@passbolt.com ?

Hello Diego.

Will do, thanks :).

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.