Passbolt CE 3.7.1 keeps directing to install extension

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

New mac, new chrome extension installation, it keeps redirect me to the same page…

Hi @webdev,

Welcome to the Forum.

Have you installed the passbolt extension?
if you do not have the extension, installing the extension would solve this issue.


I’m having the same problem as the OP, and I have the extension installed. For some reason, Passbolt just isn’t detecting the extension. Ubuntu 22.10, Firefox 106.0.2 installed from the Mozilla website, not from Ubuntu’s Snap. Further information available on request.

yes I have uninstalled, reinstalled, cleaned cache go through ONYX, etc.
I have the same issue with Chrome and Firefox.

Hi @DaddyWarlock,

Can you run the health check for passbolt. I would like to see the result and the version that is being used.

su - www-data -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt healthcheck"

Could you try brave browser and see if you get that error. I am messing around with the code so I can see if I can reproduce this and have a look at the log files to check for any errors.

If i find anything that is a concern, will pass the message to the actual Passbolt devs.


 ____                  __          ____  
/ __ \____  _____ ____/ /_  ____  / / /_ 

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell


[PASS] PHP version 8.1.11.
[PASS] PCRE compiled with unicode support.
[PASS] The temporary directory and its content are writable and not executable.
[PASS] The logs directory and its content are writable.
[PASS] GD or Imagick extension is installed.
[PASS] Intl extension is installed.
[PASS] Mbstring extension is installed.

Config files

[PASS] The application config file is present
[PASS] The passbolt config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to
[PASS] App.fullBaseUrl validation OK.
[PASS] /healthcheck/status is reachable.

SSL Certificate

[PASS] SSL peer certificate validates
[PASS] Hostname is matching in SSL certificate.
[PASS] Not using a self-signed certificate


[PASS] The application is able to connect to the database
[PASS] 26 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[PASS] The environment variable GNUPGHOME is set to /var/www/.gnupg.
[PASS] The directory /var/www/.gnupg containing the keyring is writable by the webserver user.
[PASS] The server OpenPGP key is not the default one
[PASS] The public key file is defined in config/passbolt.php and readable.
[PASS] The private key file is defined in config/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in config/passbolt.php.
[PASS] The server public key defined in the config/passbolt.php (or environment variables) is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt a message.
[PASS] The private key can be used to sign a message.
[PASS] The public and private keys can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.
[PASS] The private key can be used to decrypt and verify a message.
[PASS] The public key can be used to verify a signature.
[PASS] The server public key format is Gopengpg compatible.
[PASS] The server private key format is Gopengpg compatible.

Application configuration

[FAIL] This installation is not up to date. Currently using 3.7.1 and it should be v3.7.3.
[HELP] See. Passbolt Help | Update
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[PASS] Registration is closed, only administrators can add users.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

JWT Authentication

[PASS] The JWT Authentication plugin is enabled
[PASS] The /var/www/passbolt/config/jwt/ directory is not writable.
[PASS] A valid JWT key pair was found

[FAIL] 1 error(s) found. Hang in there!

Also tried Brave with identical results.

So I think this might be the issue

You might have the latest version of the plugin and you are using passbolt v3.7.1

Can you update Passbolt to the latest version (3.7.3) and see if it works. If it still does not work let me know and we can dig into your log files to see what is going on.

Update Link: Passbolt Help | Update


Okay, I purged my existing Passbolt installation and started fresh. I got to the web-based configuration, but it’s not letting me establish a connection to the database, whether I enter the url,,, or even the IP address of the server. Now what?

PS: the newly-installed version is 3.7.3-1, just so you know.

@DaddyWarlock The app tends to have messages at each step if there are errors. Just to clarify, can you provide the message it says and what step you are on in the guide?

The web configuration is client side access to the backend configuration so it should be unless your db is located on a machine different than the one that is serving passbolt.

Is your db installed and running? Can you log into it manually via the command line?

Active and running. At least, according to systemctl status mysql.service.

Here’s the error message: “A connection could not be established with the credentials provided. Please verify the settings.” I’m sure of the admin username, password, and dbname.

Step 2: Database


  • Is mysql running on a unix socket instead of port 3306?
  • Is db user granted proper permissions on the db?
  • Are you entering the mysql admin username instead of db user username?
  • Any mysql errors in the logs?
  1. How can I tell if mysql is running on a unix socket? Or maybe a different port?
  2. I created the db user in the installation of Passbolt.
  3. I’m using passboltadmin, just like in the installation defaults.
  4. Here are the last couple of lines in the error log:

2022-10-30 02:24:35 warning: Warning (2): file_get_contents(/etc/passbolt/gpg/serverkey.asc): Failed to open stream: No such file or directory in [/usr/share/php/passbolt/src/Utility/Healthchecks/GpgHealthchecks.php, line 456]
2022-10-30 02:24:35 warning: Warning (2): file_get_contents(/etc/passbolt/gpg/serverkey_private.asc): Failed to open stream: No such file or directory in [/usr/share/php/passbolt/src/Utility/Healthchecks/GpgHealthchecks.php, line 458]

I hope this helps!

You could test from the command line with a forced host and port parameter like this:
mysql -u <username> -p -h127.0.0.1 -P3306

If you are able to access the database in this way, it should work from the web configuration. If it doesn’t, it is not clear why. I would generally recommend starting over as the quickest way forward.

Drop the database and the user you created if you know how, or create a new database and new user. Either way, you can start again with: sudo dpkg-reconfigure passbolt-ce-server

I tried dpkg-reconfigure and got the same error, so I went into mysql and manually created the database and user. It seems to be working now. Huzzah!