Raspberry Pi install problem

Hi All,

I’m trying to install Passbolt CE to a Raspberry Pi 3, but always got errors. I have found a seems-to-be-relevant post here but that solution didn’t work for me.

I’m using the official install guide and stuck at Step 2. I have tried to modify the /etc/apt/sources.list.d/passbolt.sources and the passbolt-repo-setup.ce.sh ( https://download.passbolt.com/ce/debianhttps://download.passbolt.com/pro/debian) based on the mentioned post but without success…

Could someone help me out? Any help appreciated,
thanks in advance!

System info

PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
VERSION_CODENAME=stretch
ID=raspbian
ID_LIKE=debian

Console log:

pi@raspberrypi2:~ $ wget https://raw.githubusercontent.com/passbolt/passbolt-dep-scripts/main/passbolt-repo-setup.ce.sh
--2022-05-06 23:49:12--  https://raw.githubusercontent.com/passbolt/passbolt-dep-scripts/main/passbolt-repo-setup.ce.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.111.133, 185.199.110.133, 185.199.109.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.111.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 8573 (8.4K) [text/plain]
Saving to: ‘passbolt-repo-setup.ce.sh.2’

passbolt-repo-setup.ce.sh. 100%[========================================>]   8.37K  --.-KB/s    in 0.001s  

2022-05-06 23:49:12 (6.28 MB/s) - ‘passbolt-repo-setup.ce.sh.2’ saved [8573/8573]

pi@raspberrypi2:~ $ [ "$(sha256sum passbolt-repo-setup.ce.sh | awk '{print $1}')" = "ce96ab921e2fa448d48da018e3be0e9646791629dffb13707bbc49b55c739490" ] && sudo bash ./passbolt-repo-setup.ce.sh || echo "Bad checksum. Aborting" && rm -f passbolt-repo-setup.ce.sh
sysctl: reading key "net.ipv6.conf.all.stable_secret"
sysctl: reading key "net.ipv6.conf.default.stable_secret"
sysctl: reading key "net.ipv6.conf.enxb827ebe141dd.stable_secret"
sysctl: reading key "net.ipv6.conf.lo.stable_secret"
sysctl: reading key "net.ipv6.conf.wlan0.stable_secret"
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Ign:3 https://download.passbolt.com/ce/debian stretch InRelease
Err:4 https://download.passbolt.com/ce/debian stretch Release
  404  Not Found
Reading package lists... Done
E: The repository 'https://download.passbolt.com/ce/debian stretch Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Bad checksum. Aborting
pi@raspberrypi2:~ $ 

Hi @zolth :wave: and welcome to passbolt community forum :handshake:

It seems according to the hostname of your raspberry you are running the version 2 and not the version 3.
But that is not the problem :slight_smile: You are running Debian 9 stretch and we don’t provide any repository for Debian 9. Minimum recommended Debian version is Debian 10. You should reinstall your raspberry pi os with latest OS version: Operating system images – Raspberry Pi

Best,

Hi @_jc,

I see your point, but it is only a custom hostname, so it is a Pi 3 inside :slight_smile:. After a fresh Pi OS install it worked, thanks!

Regards,
Zoltan Hegyi

2 Likes