Unable to install Passbolt update on Raspberry Pi 2

Hi All,

I have Passbolt-ce-server installed on Raspberry Pi 2 and have been using it.
I received an email recommending an update and tried to update.
However, when I check the repository, I get a 404 error.

pi:~ $ sudo apt update
Ign:1 https://download.passbolt.com/ce/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian bullseye InRelease
Hit:3 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
Err:4 https://download.passbolt.com/ce/raspbian buster Release
  404  Not Found [IP: 2606:4700:10::6816:4687 443]
Hit:5 https://deb.nodesource.com/node_14.x bullseye InRelease
Reading package lists... Done
E: The repository 'https://download.passbolt.com/ce/raspbian buster Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Version Raspbian has cleared the minimum required version.

pi:~ $ lsb_release -a
No LSB modules are available.
Distributor ID:	Raspbian
Description:	Raspbian GNU/Linux 11 (bullseye)
Release:	11
Codename:	bullseye

When I checked the repository, I couldn’t find Raspbian.
What should I do?

https://download.passbolt.com/

Hi @Aluminum-Fairy :fairy: and welcome to passbolt community forum :people_holding_hands:

Do you have passbolt installed from source or with package ?

If installed from package, you should get this result to the below command:

dpkg -l | grep passbolt
ii  passbolt-ce-server             3.5.0-3   all          Passbolt, open source password manager for teams

If you don’t get any results, maybe did you installed passbolt from sources ? If true, you should find passbolt on /var/www/passbolt directory on your raspberry pi.

Finally, to answer to your question, we have only one repo for Debian 10 / 11 and raspberry pi flavors, as it is the same package. You should replace in your /etc/apt/sources.list.d/passbolt.sources https://download.passbolt.com/ce/raspbian with https://download.passbolt.com/ce/debian

Cheers,

Thank you for your reply. @_jc
First, whether you installed it from a package or source.
I used the package version.

pi:~ $ dpkg -l | grep passbolt
ii  passbolt-ce-server                   3.5.0-3                          all          Passbolt, open source password manager for teams

The second is rewriting the URL of the repository.
This worked.It have successfully recognized the repository and confirmed that 3.5.0-3 is up to date.
thank you for your cooperation.

Cool :+1: don’t hesitate if you have further questions.

Best,

1 Like