Records automove to /root [fixed since v3.8.4]


First time on forum and new passbolt user here - business user.

Since we are new and trying to populate our passbolt space, we are trying to make it better.
Users are spread into groups. My user is a user type (not admin). When I create a record inside the folder everything works just fine. I’m the owner of the record and owner of the folder.
If I want to move my record into a different folder (that I own as well), it drops into /root folder. Admins, who has access to the same folder sees the record inside the designated folder as it should be.


  • change user type from user to admin
  • change folder share is owner / can update
  • cleared browser cache
  • tested on different browsers (Edge/Firefox/Chrome)
  • tested on a different pc

Is this a configuration thing our admins missed or do I need to be an admin in order to populate records for other inside the group?

Thank you in advance


Hmm user role should not change anything here.
When you said change folder share from owner to update you mean for who?

Difference between update and owner is that only owner can change the sharing list.

I will be happy to have a screen share if you want to show the scenario to me, do not hesitate to DM me.

I will post back the result of that call here for sharing.


1 Like

Hi Max,

What I do is the following:


  • Create a Folder under my space
  • Share this folder with the IT group we have (owned or update brought same results)
  • Create a password record withing this folder.
  • Create a 2nd folder outside my 1st folder (it’s not a subfolder, but same level folder)
  • Share this same folder with the IT group.
  • Move my record from folder A to folder B

After my password record is moved, It’s no longer present in folder A, but also not present in folder B, but only for me. My boss who’s user is admin, can see my record in folder B, where I see my record now in /root folder.
Doesn’t matter if I try to move to a different folder, it will have the same behavior.

Troubleshooting with the steps from my 1st post.
I’ve solved the issue with deleting my password records in root and re-created them again in the correct folders but this is not a solution.

I don’t have access to configurations or admin users as of now. If this is something we need in order to troubleshoot this, I might arrange a date/hour with my boss to have a look into it.


Hey @amsidc this sounds a lot like an issue we had before that was taken care of in a release late last year.

I know you said you are new to Passbolt so I assume you are on a more recent version, but could you check which version you are on? If you log in there is a small heart at the bottom right corner of the page, if you hover over that it’ll say what version you are on and which the browser extension is.

Since you mention you don’t have an admin user I’m not sure if you’ll be able to do this part as it requires server access but could you run the cleanup command as a dry-run and send us the output?
Example for Debian:
su -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt cleanup --dry-run" www-data

If it shows some things to clean up you might want to run it without the --dry-run

1 Like

Hi @clayton
It shows me 3.8/3.10 version. I assume 3.8 is the software version, 3.10 being the browser agent then.
I’ll pass your suggestion to my boss if possible to upgrade versions and let you know the results, but
reading the notes, I’m confident this will solve my issue.

Thanks in advance.

1 Like

Hi @clayton

Confirming update to 3.11 solved the issue. Thank you for the support.

1 Like