SQL Failure During Initial Configuration

Hi Everyone,

I’ve been trying to get the community edition of Passbolt up on my Ubuntu 20.04 server to test it out before the deployment for a couple of days now but have been unable to proceed past the SQL setup portion of the configuration. I have followed through the guide listed here to get everything setup.

After successfully completing the installation process, I move to the browser portion of the setup and all the health checks other than SSL are successful since this is a test envirornment and I’m accessing the server via local IP address. At the next page of the setup where you need to enter your database details, I entered the details that I had provided to the installer previously, only to be met with the following:

I am at a complete loss with this. I’ve tried everything under the sun that I can think of and I’ve completed wiped my system and started from fresh on multiple occasions but have hit the same block in the road every single time. I have verified that I am able to connect to my SQL database locally via terminal with the credentials that I entered in the above screenshot and I get the following:

mysql> status

mysql Ver 8.0.26-0ubuntu0.20.04.3 for Linux on x86_64 ((Ubuntu))

Connection id: 27
Current database: passboltdb
Current user: root@localhost
SSL: Not in use
Current pager: stdout
Using outfile: ‘’
Using delimiter: ;
Server version: 8.0.26-0ubuntu0.20.04.3 (Ubuntu)
Protocol version: 10
Connection: Localhost via UNIX socket
Server characterset: utf8mb4
Db characterset: utf8mb3
Client characterset: utf8mb4
Conn. characterset: utf8mb4
UNIX socket: /var/run/mysqld/mysqld.sock
Binary data as: Hexadecimal
Uptime: 5 min 27 sec

Threads: 2 Questions: 16 Slow queries: 0 Opens: 180 Flush tables: 3 Open tables: 99 Queries per second avg: 0.048

I’m not sure what steps you would have to take to reproduce this issue. As previosuly mentioned, I did nothing but follow the offical instructions linked on passbolt’s offical website. Any help is greatly appreciated as I’ve been wanting to play with this software for quite some time now but have yet to be able to sample it. And I’ve had a lot of difficulty finding information online related to my issue.

Please help good people of the Passbolt Community. You’re my only hope.

From depth of the galaxy, your call I heard my young padawan :grinning_face_with_smiling_eyes:

If I am not wrong, MariaDB root user can only connect through unix socket and not from a TCP one like 127.0.0.1 on Ubuntu servers.

On your mysql status command:

mysql > status
(...)
Connection: Localhost via UNIX socket
(...)

If you try to connect as mysql root user with -h 127.0.0.1 argument, it will fail on Ubuntu.

By the way, using mysql root user can seems easier, but this is definitively the path to the dark side of the Force. You should use the dedicated mariadb user created at this step of the documentation:

This is the way :wink: And the dedicated user will be able to connect to 127.0.0.1.

May the Force be with you, always.

1 Like

JC,

Oh my Good lord I’m such an idiot. You have no idea how long I have been fighting with this issue and it turned out to be such a simple mistake lol. Thank you so much for the help man! After I entered the correct details this time, it worked beautifully.

I look forward to giving this fotware a test run now thanks to you!

No pbm :slight_smile: it happens to everyone to do some typos. Solutions are often in front of us but we don’t see them :slight_smile:
Enjoy your Passbolt instance :muscle:

1 Like