Installation Stuck at "Checking status"


I’m having my second major issue at the inital setup of my test Passbolt instance. My server is running a fresh install of Ubuntu 20.04 and there is nothing else running on it besides passbolt. I followed the offical guid to get Passbolt setup and configured which can be found here. The actual installation on the server goes just fine with out hiccup but as soon as I access the server via a web browser and go through the configuration, it locks up at the installation step. This is what I see:

I’ve left it like this for hours before and it never proceeds past this step. If I attempt to close out from this tab and access the server again from my web browser, I get a prompt asking me for my account email. Once entering my account email, it says that it’s going to send me a confirmation request to my email. Of which I never recieve. I can only guess this is because I never got sent to the next screen where I can download the extension and setup my admin user password.

I’m honestly really not sure where to go from here. I’ve tried a couple of things to attempt to woraround this issue. I’ve tried allowing for outside users to setup accounts in an attempt to setup an account with a different email but it still won’t send a confirmation email for the normal user. I’ve tried disabling browsers extensions to see if something there was blocking it with no success either. I’ve reconfigured the server from scratch probably a dozen times trying various things server side to see if maybe there was something I was doing wrong during the install or during the configuration but I’ve gotten nowhere.

Any help is greatly appreciated. I’m on day number 4 or 5 now trying to get a simple test server setup and this is my second community post just to get past the initial setup. I’m very desperate to get this up and running. I just want to test it out.

As I said in my previous post, help my passbolt community, you’re my only hope.

Hi @Birthday_Cakeman ,

Did you check this help page => Passbolt Help | Why are my emails not being sent? ?

Can you send us the output of this command ?

sudo -H -u www-data bash -c "/usr/share/php/passbolt/bin/cake passbolt send_test_email --recipient=user@domain.tld"

And this one ?

sudo -H -u www-data bash -c "/usr/share/php/passbolt/bin/cake passbolt healthcheck"

If you are using docker on your PC or Mac, and if you just want give a try with Passbolt, I may have a solution for you. Just for evaluate Passbolt. Let me know if you are using docker and if you are interested.

Hi JC,

Thank you for the quick response. I just ran the two commands you posted. The first command through the following error:

Could not send the test email.
Error: SMTP server did not accept the connection or trying to connect to non TLS SMTP server using TLS.

Which is very confusing to me since I just set this up and during the setup I tested my SMTP settings and I was able to send a test email with no problems what so ever. I’m currently using Google’s SMTP server that I have setup within Google Workspace. I currently have it configured to accept SMTP requests from my IP address and to require TLS. Again, both things that appeared to work fine while doing the inital setup.

As for the health check, it did through two errors. However, those two errors are for SSL not being forced and HTTPS not being enabled. Both of which should be the case as I’m only accessing this from it’s local IP address for the time being.

Also I do appreciate it, however I’d like to attempt to get it up and running within the server envirorment. The deployment and maintenance of the software is part of my evaluation. So far I must say, specifically the SMTP part of the installation has been a bitch and a half. Although I can’t really faulter Passbolt for all the issues I’ve been having.

Do you happen to know of a free SMTP service I could try so I can attempt to swap over to that and get this thing up and running?

If you want just a SMTP server for testing your Passbolt instance, you can try Mailhog. Mailhog is a SMTP catcher with a web UI.

The easy way for you to install it is to install golang package with git and install Mailhog:

sudo apt install golang-go git
go get

The path to Go’s bin files on Ubuntu is ~/go/bin/ , so to start the MailHog run:


Mailhog listen for incoming emails on port 1025. So let Mailhog running, and on another terminal, you can now edit EmailTransport section of /etc/passbolt/passbolt.php passbolt configuration file as follow:

    // Email configuration.
    'EmailTransport' => [
        'default' => [
            'host' => '',
            'port' => 1025,
            'username' => null,
            'password' => null,
            // Is this a secure connection? true if yes, null if no.
            'tls' => null,
            //'timeout' => 30,
            //'client' => null,
            //'url' => null,

From now, all emails sent by Passbolt will be catched by Mailhog ! To see them, go to the Mailhog UI on http://ip.if.your.server:8025

You can now retry the send_test_email command in my post above, it should work and you will see the email in Mailhog web UI.

Remind yourself than Mailhog must run to be able to catch email. If you reboot your server, you have to relaunch it.

1 Like

Hi JC,

Thank you for your continued support! I went ahead and tried MailHog as you suggested and it appears to have worked! The installation still gets stuck at “Checking status” but opening the Passbolt server up in a new tab and typing my email in, did allow it to send an email to MailHog and allow me to complete the Passbolt configuration. I suppose, I’ll need to investigate why Google’s SMTP server isn’t working on the Google side of things and play around with that until I can get it working. There must be some configuration someone that I messed up or something. Might have to get in contact with their support but I digress.

I can’t thank you enough for your support. Looks like I’m going to be able to give Passbolt a go in my test server after all thanks to you!

A post was split to a new topic: Problem with emails and GMail