Login problems after the instalation

Hello gentlemen! First, forgive me for my English. I’m Brazilian!
After installing Passbolt On-premise, I’m having trouble logging in other users, or even logging in as my user on another machine or browser.
Whenever I access my server’s IP, I land on a screen to check my email address, and when I click next, it says an email has been sent with a link to verify my email. But this email does not arrive!
My SMTP server is functional, I’ve already tested this.
Any tips on how to proceed?
Thanks for listening!

Hello @gus,

Welcome on the forum! Have you checked the troubleshooting page?

Hello @remy, thanks for reply!
Yes, I was checking the troubleshooting page earlier today.


Can you tell us a bit more which method you used to install passbolt? Which items in the troubleshooting page what you checked?

If the send test email is working most likely it is related to the cron not being set. If the cron is working there should be some errors in the cron job logs (their location depends on your installation method).

So my friend @remy,
I installed Passbolt CE on AlmaLinux 8. I followed the standard installation step by step described on this page > Passbolt Help | Install Passbolt CE on AlmaLinux 8
On the troubleshooting page I checked the following items:

  • Reason 1: Configuration issues
    test email sending without problems
  • Reason 2: Email notifications are disabled in the config
    all forms of notification are enabled
  • Reason 3: The cron system is stopped
    the crond.service service is up and running, however, on the troubleshooting page, it is described for me to check the service with the command sudo systemctl status cron.service. When run I get the following error:
    Unit cron.service could not be found.
    Is that the problem?

Finally, I cleared the data model cache as it says in “Reason 4: There is an issue with the database schema related to the email queue”

Hey @gus for AlmaLinux I believe you’ll want to try: sudo systemctl status crond.service for Reason 3

Hi @clayton,
So, that’s what i did!
It’s running…

hello guys,
I managed to solve my problem!
By an oversight, I “skipped” step 2.3 of the installation and did not create the GPG keypair.
I up a new VM, redid the installation step by step and it worked!

Thanks for listening!

1 Like