Installing passbolt in openmediavault [install Docker on OMV]

Hello, i tried to install passbolt on my home sever with openmediavault 6 which is based on Debian 11. I used this web site and it is not installing and it’s in portuguese but it’s saying unable to find package passbolt-ce-server.

sorry if my english was not verry good.

Hi @aalvelos Welcome to the forum!
Since you are not installing on a plain vanilla server, there is a risk that the package installation would override your existing setup.

As an alternative, if you are comfortable with work on a server, you could install from Source as explained here: Passbolt Help | Install passbolt API from source

you said there is a risk that the package installation would override my existing setup
does that mean it was going to destoy my whole system ?

I think that would be the definition of malicious, which it is not. From the install page you referenced in your first post:

From the screenshot in your first post:

The package install automates the installation of everything that is needed. It’s designed to be installed on a fresh (plain vanilla) Debian install, with no other systems installed.

In comparison, by installing from source you have control over each step of the installation and can make decisions that are appropriate for your existing setup.

so its better to install it with the source code ?

It’s better to install into one of the recommended OSs.

openmediavault is a NAS management system. A quick look at their 3rd party plugins shows they are related to file management and image processing tools. I don’t see anything about running web apps.

However the forum has user guides regarding installing Docker.

Passbolt offers a Docker install method. You could ask their forum for more guidance about installing Docker and if that goes well, try the passbolt Docker method.

ok, thank you i will try with docker

1 Like

i tried by docker and did not went well it i used this web site and when a typed the comand of step 4 it gave me this erro.

Make sure to follow the instructions. Not supposed to be run as root.

sorry, yesterday i forgot to tell you i skiped step 3 but it created the conteiner how do i delete a container?
Captura de ecrã de 2023-03-26 11-17-38

This page is your friend Use the Docker command line

Click on any command for details.