Passbolt extension chrome - NotFoundError after v4 upgrade (testing, from 2.7.1)

Hello, the chrome extension has stopped working. The extension has been updated automatically and now I can’t copy the passwords and use the extension.

the extension error

The extension was working fine but today with the new update, it no longer works.


Hello and Welcome to the forum @Pedrito !

I’m sorry to read that!

In order to have better insight of what happens, is it possible for you to give the browser extension logs to see what’s happening please?

If you’re ok with that, here’s the procedure to follow.

You can go to your extensions pannel:
→ Right click on the Passbolt Icon and then “Manage Extension”

In the panel you can see the “developer mode” toggle on the top-right corner of the panel. You need it to be activated to see the logs.

Once activated you should see in the Passbolt extension card a “index.html” link. Clicking on it will open a new window with tabs. There is a “console” tab. You can click on it and copy-paste what’s in the window.

Thanks in advance :pray:

1 Like

Thanks @Steph for your reply.

This is the log
IP_ADDRESS:1443/auth/is-authenticated.json:1 Failed to load resource: the server responded with a status of 404 (Not Found)
index.html:1 Unchecked runtime.lastError: The extensions gallery cannot be scripted.
vendors.min.js:2 Uncaught (in promise) Error: The extensions gallery cannot be scripted.
at vendors.min.js:2:491789
index.html:1 Unchecked runtime.lastError: The extensions gallery cannot be scripted.
IP_ADDRESS:1443/auth/is-authenticated.json:1 Failed to load resource: the server responded with a status of 404 (Not Found)
index.min.js:2 NotFoundError: NotFoundError
at kt.isAuthenticated (index.min.js:2:70678)
at async Kt.checkAuthStatus (index.min.js:2:74175)
at async Bn.main (index.min.js:2:230783)
main @ index.min.js:2
index.min.js:2 GET https://IP_ADDRESS:1443/auth/is-authenticated.json 404 (Not Found)
kt.isAuthenticated @ index.min.js:2
checkAuthStatus @ index.min.js:2
isAuthenticated @ index.min.js:2
assertUserAuthenticated @ index.min.js:2
canBeAttachedTo @ index.min.js:2
(anonymous) @ index.min.js:2
getPagemodThatCanBeAttachedTo @ index.min.js:2
exec @ index.min.js:2
exec @ index.min.js:2
await in exec (async)
exec @ index.min.js:2

I have changed the IP address of the server for “IP_ADDRESS”, passbolt is installed in a server with docker. Other people can use it now without any problem with an older version of the extension and I was using it this morning.


Hi @Pedrito,

Could it be possible to know the version of your server? Did you lock it inside your docker-compose file?

Silly trick as well, can you try to do a https://<YOUR_URL>/logout to clean any remaining session

Thanks in advance,

It looks like your server version is outdated, like you are running an API prior to version v2.11.
Can you confirm?

I close the browser and I also reboot the computer.
And yes, the version is 2.7.1

Is possible to upgrade the vesion without losing the data?

The best would be to do the following:

  • Install a previous version of the browser extension so that you are not pressured by time to perform the upgrade and make a mistake. Cedric will post an how-to in this thread.
  • Make a backup of your SQL data using mysqldump (or alternatively an export of your data using Keepass export feature). This is to prevent loss of data in case you didn’t mount your SQL data on a separate partition / never rebooted the container.
  • Locally try to run the ugprade with your exported data, and try to run the upgrade. Passbolt Help | Migrate an existing Passbolt CE to a new Docker Report back some errors here (we have not tested an upgrade with a v2.7.1 for a long time but it should work, but better be safe and try it first).
  • Perform the upgrade in your production environment
1 Like

If you need an immediate access of your passwords and you have a copy of your private key, you can still install an old extension as my colleague mention it.

  1. Download the extension from github:

  2. Unzip the extension build

  3. Disable (not remove) the extension v4.0.0

  4. Go to the extensions management interface: chrome://extensions/

  5. Load the extension by clicking on “Load unpacked” and select the folder “build/all” of the uncompressed zip.

  6. Initiate a recover process IP_ADDRESS:1443/users/recover

Thanks @cedric and @remy :wink:

I’ll fix it


Good luck @Pedrito !

1 Like

Hey, I have the same Problem.

But i didn’t have my Public Key. And doesn’t let me download it after the Update.
Is there any way how I can recovery my Passbolt?

Hello @ReifenMueller,

What version of the API are you running?

As explained earlier in this thread, if you are running a version older than v2.11.0 then the backward compatibility was broken with the v4.0.0 of the browser extension. In that case you need to upgrade your API to a version > v3. Checkout this comment

If you need to access your passwords quickly, a workaround consists in installing an older version of the API in parallel of the one you already have , checkout this comment

If you don’t have a copy of your private key, and you still have installed the browser extension that was automatically updated to its version 4.

You can open the debug console of the browser extension and try to access your key as following:

  1. Go to the extensions management interface: chrome://extensions/
  2. Enable the developer mode in the top right of your screen
  3. On the passbolt extension v4 tail click on index.html
  4. Go to the console tab of the developer tool
  5. Execute the following command in the console'_passbolt_data', data => console.log(JSON.parse(data._passbolt_data['passbolt-private-gpgkeys'])['MY_KEY_ID']['armored_key']));


I had the same problem and I have already solved it updating the version but now I have another problem. Users who use Firefox can’t login and get the ErrorNotFound message. The extension in Firefox has not been updated and is still version 3.12. When will the new version be available?

Kind regads.

Hello @cristian and welcome on the community forum.

The extension v3.12.1 is compatible with the API v4.0.0 regarding the issue discussed in this thread. Your users might encounter another issue.

Could you please copy here the output of the Firefox browser extension log:

  1. Go to the extension debugging page about:debugging#/runtime/this-firefox
  2. Click on the Inspect button of the passbolt extension tail.
  3. Checkout the log from the console tab.

I will add it as a note, but did you try to switch it off and on again? There might be a cache issue here.

Ohhhh! Users using Firefox have restarted the browser and it is now working correctly. They should have tried this before writing here. @cedric sorry and thanks!


Hello @cedric ,

Thanks for your help.

I try to execute the command but nothing happen,


I succesfully change the browser extension on Firefox to pass to v4.0, but it seems more sensitive on Chrome and I have one user who (I know…) doesn’t keep his private key. I would like to move him to firefox but without this private key it seems impossible.


If you’re experiencing issues with the command, there could be a few reasons why it’s not working:

  1. Please verify that you’re running the command on the correct profile. Double-check to ensure you’re using the intended profile for the command execution.
  2. It’s possible that the user may have uninstalled the browser extension. In that case, it will be complicate to retrieve the private key.

Could you please attempt to execute the following command:

can you try to run :'_passbolt_data', data => console.log(data._passbolt_data['config']['user.username']));

If the username is empty, it indicates that the browser extension setup has not been completed.

Let me know,

Colart Pierre

1 Like