Troubleshoot: installing Passbolt on Virtualbox

Hello,

This is my first time installing Passbolt in Ubuntu 20.04 and I am now on this part:

Installation is almost complete. Please point your browser to
** http://10.2.0.15 to complete the process**

But when I go to the browser it is only loading and the output is The server at 10.2.0.15 is taking too long to respond.

I have attached screenshot for reference.

Thank you

I have also allowed the firewall connection
ub1

Hi @sixela011 Welcome to the forum!

Can you verify which installation method or guide you are following?

Next steps would be:

  • ensure your client machine is able to access the host machine (ping)
  • check webserver logs on host machine for traffic and or errors (assuming NGINX look in /var/log/nginx folders.

I’m sorry I input the wrong hostname that is why I cannot view it in the browser. I can now view the nginx page

Follow up question Garrett, How can I access this part?
ca

@sixela011 If the host machine is running Ubuntu, make sure to install the Ubuntu package which is designed to install on a fresh machine. It will install NGINX and configure it for you.

If you are just looking to take it for a spin and try it out, the Pro edition has a virtual machine install option: Passbolt Help | Using Passbolt pro virtual machine appliance which the easiest and quickest to install.

Hello Garrett,

I tried this link for the installation

But I still got an error

I also tried this one Passbolt Help | Using Passbolt pro virtual machine appliance and already downloaded the ova and the SHA512SUM.txt but when I boot in the VM it is only black.



You forgot the special goggles! Just kidding.

@_jc do you know what causes a black screen like this?

I am having hard time installing passbolt :rofl:
I tried solution from google but got the same error.
Thank you for your patience.

Hi :wave:

You got a black screen because with Virtualbox, default selected system is a Linux 32-bit

You should select Debian 64bit:

Regarding your first issue:

10.2.0.15 is the default virtualbox NAT network, you won’t be able to reach this IP from your computer.

If you want to use NAT, you have to define port forwarding:

As an example, here are my settings:

  • 8080 to access to VM port 80
  • 4443 to access to port 443
  • 22222 to access to ssh port 22:

I usually use bridged adapter to “plug” my VM network to my Wifi or Eth card:

Thus, I can use my home network to access to my passbolt VM. If you choose bridged adapter, you should fix the IP address:

Hope this help :slight_smile:

2 Likes

Thank you @_jc and @garrett I successfully installed the passbolt :grinning:

1 Like