[v2.0.0-rc2] That version of GPGAuth is not supported and server key not in keyring

the problem: After upgrading my passbolt installation from 1.9.6 to 2.0.0RC1 im getting the error
that version of GPGAuth is not supported .

system: Ubuntu 16.04 php7

Here is my healthcheck:

 ____                  __          ____  
/ __ \____  _____ ____/ /_  ____  / / /_ 

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell


[PASS] PHP version 7.0.22-0ubuntu0.16.04.1
[PASS] PCRE compiled with unicode support
[PASS] The temporary directory and its content are writable
[PASS] The public image directory and its content are writable
[PASS] The logs directory and its content are writable

Config files

[PASS] The application config file is present
[PASS] The passbolt config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to
[PASS] App.fullBaseUrl validation OK.
[PASS] /healthcheck/status is reachable.

SSL Certificate

[PASS] SSL peer certificate validates
[PASS] Hostname is matching in SSL certificate.
[PASS] Not using a self-signed certificate


[PASS] The application is able to connect to the database
[PASS] 19 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[FAIL] Do not use the default gpg key for the server
[HELP] Create a key, export it and add the fingerprint to config/passbolt.php
[HELP] See.
[PASS] The environment variable GNUPGHOME is set to /home/www-data/.gnupg.
[PASS] The directory /home/www-data/.gnupg containing the keyring is writable by the webserver user.
[PASS] The public key file is defined in config/passbolt.php and readable.
[PASS] The private key file is defined in config/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in config/passbolt.php.
[FAIL] The server key defined in the config/passbolt.php is not in the keyring
[HELP] Import the private server key in the keyring of the webserver user.
[HELP] you can try:
[HELP] sudo su -s /bin/bash -c “gpg --home /home/www-data/.gnupg --import /var/www/passbolt_api/config/gpg/unsecure_private.key” www-data
[PASS] There is a valid email id defined for the server key.

Application configuration

[PASS] Using latest passbolt version (2.0.0-rc.1).
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[PASS] Registration is closed, only administrators can add users.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

2 error(s) found. Hang in there!

And in the logs i see
2018-01-29 10:34:43 Error: [Cake\Network\Exception\InternalErrorException] The GPG Server key defined in the config is not found in the gpg keyring

however i already tried the command to put it into the users keyring and it should be there.

[x ] I have read intro post: About the Installation Issues category
[x ] I have read the tutorials, help and searched for similar issues
[ x] I provide relevant information about my server (component names and versions, etc.)
[ x] I provide a copy of my logs and healthcheck
[ x] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Have you tried importing the key manually?

sudo su -s /bin/bash -c “gpg --home /home/www-data/.gnupg --import /var/www/passbolt_api/config/gpg/unsecure_private.key” www-data

What do you get with:

sudo su -s /bin/bash -c “gpg --home /home/www-data/.gnupg --list-keys” www-data


sudo su -s /bin/bash -c “gpg2 --home /home/www-data/.gnupg --list-keys” www-data

I already tried manually importing it says this:
@vault:/var/www/passbolt_api$ sudo su -s /bin/bash -c “gpg --home /home/www-data/.gnupg --import /var/www/passbolt_api/config/gpg/unsecure_private.key” www-data
gpg: key 573EE67E: already in secret keyring
gpg: Total number processed: 1
gpg: secret keys read: 1
gpg: secret keys unchanged: 1

@vault:/var/www/passbolt_api$ sudo su -s /bin/bash -c “gpg --home /home/www-data/.gnupg --list-keys” www-data

pub 2048R/91CC9A01 2017-10-05
uid testkey emaill@email.nl
sub 2048R/378C5672 2017-10-05

pub 4096R/573EE67E 2015-10-26 [expires: 2019-10-26]
uid Passbolt Server Test Key no-reply@passbolt.com
sub 4096R/D0A5D96B 2015-10-26 [expires: 2019-10-26]

with the last commands it shows all keys from all users

What about running the same command using gpg2 (instead of gpg) ?
We’ve seen issues with keyring created with gpg2 and key being imported from gpg under unbuntu.

1 Like

YES thank you that worked :slight_smile:

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.