An Internal error has occured

[x ] I have read intro post: About the Installation Issues category
[x ] I have read the tutorials, help and searched for similar issues
[ x] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[x ] I describe the steps I have taken to trouble shoot the problem
[] I describe the steps on how to reproduce the issue

I just finished a fresh installation of Passbolt in a Cent OS server with mysql database
healthcheck is running properly, only fail is that Passbolt is not configured to force SSL use but I am skipping as I have a load balancer before the passbolt server that has a ssl installed so my passbolt installation works on https
I was able to create the user but when I click on the link I get the error below:

“An internal erro has occured”

I can only go to home where I can see links to the documentation and login which will not go anywhere

check the error logs and the only error I can see is the one below:

2018-06-01 23:13:44 Error: [PDOException] SQLSTATE[HY000] [2002] Permission denied
Request URL: /setup/install/3f194e03-cfc3-4b65-8d67-cd49d0f169fc/702a8f3a-0dba-4cb8-9f11-75019496b286

Any help will be really appreciated


Hi @luis.horna
According to the logs it’s a mysql connection issue. But since you created your user without encountering any error that seems weird.
Can you try these 2 steps:

  1. clear your cache (as nginx user): ./bin/cake cache clear_all
  2. try to create another user and see if it happens again

If it still happens, then please add the following line 'debug' => true, line at the top of the config instructions in ./config/passbolt.php, and try to access the page again. A screenshot of what is shown on your screen would be helpful.


Thanks for the reply, I appreciate it
I tried the suggested steps:
Cleared cache and created a new user and I got the same error when following the link sent by email
Enabled debug option and attached is the screen shot with the information

Thanks again for the help



Could it be related to selinux ?

selinux avoid db connections from the httpd server to the remote db server.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.