/app/users website doesnt work

Hello all!

Im having the following problem, the other day Passbolt stopped working for us, I checked machine and noticed that the disk was almost full, so I increased the volume (this VM its on AWS) and retried it. As first sight, everything works fine, mails are being send, passwords are there… but when we click on the users tab from the website, the red loading bar at the bottom doesnt finish the load, and the site seems to be unresponsive on the users part (cant search or select any user). I have to say that the guy that set this up is not in the company anymore so I’m not really sure what he did… I can say that the installation is made with docker and the version is 2.9.

Anyone experienced something like this before?

Thanks in advance!

Hi @EsE We just rolled out a new browser extension the other day. This triggered some issues in certain cases. Please check Users are not showing up on the console - #4 by nijazse which sounds like what you are describing but also Browser extension v3.0.0 - data issues identified for users using passbolt since v1 which has a short list of links at the bottom to other possible issues.

Please feel free to post back if you still need help or if it resolves the problem for you.

Also, 2.13.5 is the most recent version so an update is needed.

Hello @garrett , thanks for pointing me out. I tried to do what in those other threads say and indeed it seems the same error. I tried to do the same command

sudo -H -u www-data bash -c "/var/www/passbolt/bin/cake passbolt cleanup --dry-run"

But for some reason that path doesnt exist:

bash: /var/www/passbolt/bin/cake: No such file or directory

This is the docker-compose.yml:

version: '3.4'
    image: mariadb:10.3
      - env/mysql.env
      - database_volume:/var/lib/mysql
      - ""

    image: passbolt/passbolt:2.9.0-debian
    tty: true
      - db
      - env/passbolt.env
      - gpg_volume:/var/www/passbolt/config/gpg
      - images_volume:/var/www/passbolt/webroot/img/public
      - /run
    command: ["/usr/bin/wait-for.sh", "db:3306", "--", "/docker-entrypoint.sh"]
      - 80:80
      - 443:443


I tried using the command locate cake but it seems that in my case, the cake is a lie:


Thanks and regards!

Hi @EsE The Debian version in the Docker image will need the command to be:

sudo -H -u www-data bash -c "/usr/share/php/passbolt/bin/cake passbolt cleanup --dry-run"

The file is located differently. Sorry for the hassle on that one, I will add a note in that link.

EDIT: This is incorrect - my apologies. As of Feb 2021 the Docker image is not using this command.

Hello garret,

We tried the following commands with this output:

Please, could you take a look and help us?


hi @EsE,

If you are running passbolt on a container you can execute the cleanup without installing sudo:

su -c "/var/www/passbolt/bin/cake passbolt cleanup --dry-run" -s /bin/bash www-data

Using sudo will clean the environment and so the cleanup task would not be able to find the required environment variables.

If you still want to use sudo you should add a -E like this:

sudo -H -E -u www-data bash -c "/var/www/passbolt/bin cake passbolt cleanup --dry-run"

Hope this helps.

Hello Diego, that worked!

Thanks to you and garret for the help!

1 Like