[DEBIAN] first-time configuration fails after adding user

[X] I have read intro post: About the Installation Issues category
[X] I have read the tutorials, help and searched for similar issues
[ ] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[X] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Hi there!

I am trying to install a fresh passbolt-installation on a hyper-v VM, I have tried both Debian 10 and Ubuntu 18.04.

The issue is that I get this screen:

As soon as I press “next” after creating the first user in the wizard.

I cannot seem to find any /var/logs and I have tried both fresh debian and ubuntu’s.
Does anyone have any ideas on this?


Hello @Kimmag

Which method did you use to install passbolt? Did you use the installation scripts or did you do it manually?

Hi there!

I have used the scripts on both distro’s as I am not a master in linux and manually installing php and other stuff so yes - the scripts.

Do you see any information in /logs/errors.log in on the passbolt directory in your webserver?


/var/log/nginx/error.log is empty - and it is only a default-folder in etc/nginx/sites-enabled.

Am I looking in the wrong place?

Hi @Kimmag,

Usually the install scripts write a log on a file called install.log have you checked if there are any errors there?

Hi there!

There is no errors in the install.log, the only thing I could find is this:
“gpg: WARNING: unsafe permissions on homedir '/home/www-data/.gnupg”

I do not know if this is relevant.

I have just ran the scripts on debian 10 locally on a virtualbox VM and I can’t reproduce.

Have you checked if your database is populated and that you can access with the same credentials you provided during the webinstall to the database?

Hi there!

I figured out what was most likely wrong - I used a “-” (dash) in the database-name.
I facepalmed myselves, I should’ve known this.

Thanks for all the help everyone!

Hi…If you’re running this in a VM anyway, I’d definitely recommend switching to Linux. The application will work in any environment that runs Apache/PHP/MySQL, but some of the media processing tools we use to extract previews from uploaded images, documents and videos (ffmpeg, ghostscript) can be a little hard to set up right in a Windows environment. Just search this forum for “Windows” and you’ll find a bunch of examples :-). In most current Linux distributions you can install most of the tools needed from the package manager.