Duo error on setup attempt [fixed with 3.11.1]

[Y ] I have read intro post: About the Installation Issues category
[ Y] I have read the tutorials, help and searched for similar issues
[y] I provide relevant information about my server (component names and versions, etc.)
[ y] I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Ubuntu 22.04 Setup using the Pro Ubuntu Installation Guide from PassBolts Site
Running 3.11.0 - Regular from APT install

Error that pops up is "2023-03-02 22:07:45 notice: Notice (8): Undefined variable: setupForm in [/usr/share/php/passbolt/plugins/PassboltCe/MultiFactorAuthentication/templates/Duo/setup_error.php, line 35]
" when Duo returns me from the Duo auth work screens to Passbolt.

This error pops up when trying to enable Duo on my user. I was able to enable TOTP without issue.
HTTPS is enabled and site is accessible from the internet. (WANT to have it completely behind our firewall but am troubleshooting Duo so its not at the moment.)

Reproduction of the issue just requires me to attempt to enable Duo on my user.

1 Like

May be related to: Error configuring MFA

No word yet from devs on this.

I submitted a support ticket as well as we are Pro subscribers so hopefully I’ll hear something from that end.

1 Like

Hello @earlgrei,

Thanks for the report.

Passbolt is expecting from duo to send an email that match the account on Passbolt but some accounts are using an another identifier. So the team is doing a fix to take those scenarios in consideration.
An announcement will be published on the forum once the fix is ready. :slightly_smiling_face:


I was able to confirm this to be the issue. Thanks for working on it. I created a Duo and Passbolt test account with the username on both as a full email address and everything worked as expected. Thanks.


Ok the fix 3.11.1 is done and we will release it on monday

Monday because


HAHAHAHAHAHAHA Oh god. If I could like this post a dozen more times I would. I can’t even argue with it. Its too perfect. Sounds good thank you for the fix.

1 Like

I got alerted that there was a push to the docker image for 3.11.1 so I went ahead and updated. It looks like it worked but I see this still on the health check. Just as an FYI.

1 Like

I think it may be a typo, but the next fix version is in the works. The extension is already at 3.11.1. I think safe to ignore for now.

Just confirming here, v3.11.1 does have an issue where it will show as 3.11.0 instead of the correct version.


I appreciate this type of accountability more than you could possibly imagine! Thank you so much!